Author Poor running between 2000 and 3000rpm  (Read 2485 times)

0 Members and 1 Guest are viewing this topic.

  • Offline tekjess   us

    • ZH2 Junior Member  ‐    2
    • *
      #20

    Offline tekjess

    • ZH2 Junior Member
    • *
    • Posts: 2
    • Bike: 2020 ZH2
    • Town / City: San Antonio
    • Country: us
    Re: Poor running between 2000 and 3000rpm
    Reply #20 on: December 04, 2022, 06:42:19 pm
    December 04, 2022, 06:42:19 pm
    I had the brent tuning flash done to my ZH2 and it began stuttering/chattering between 2k and 3k. I took off the O2 sensor and everything worked fine.

  • Offline wallycycle   us

    • ZH2 Pro  ‐    139
    • ***
      #21

    Offline wallycycle

    • ZH2 Pro
    • ***
    • Posts: 139
    • Town / City: Murrieta
    • Country: us
    Re: Poor running between 2000 and 3000rpm
    Reply #21 on: December 06, 2022, 02:43:49 am
    December 06, 2022, 02:43:49 am
    I didn't f--k with my bike's fueling/air in any way. Smooth as silk.

  • Offline Marco   gb

    • ZH2 Member  ‐    65
    • **
    • Topic Author
    • #22

    Offline Marco

    • ZH2 Member
    • **
    • Topic Author
    • Posts: 65
    • Bike: ZH2
    • Town / City: Carrickfergus
    • Country: gb
    Re: Poor running between 2000 and 3000rpm
    Reply #22 on: December 06, 2022, 08:43:45 am
    December 06, 2022, 08:43:45 am
    *Originally Posted by tekjess [+]
    I had the brent tuning flash done to my ZH2 and it began stuttering/chattering between 2k and 3k. I took off the O2 sensor and everything worked fine.

    A mate got his done and it turns out the O2 sensor was the culprit on his as well.